sábado, enero 20, 2007

OpenOffice 2.1.0 para Ubuntu

Lanzado el nuevo OpenOffice 2.1.0 en el que se han mejorado muchas cosas entre ellas la compatibilidad con la importación de documentos de Microsoft.

Podéis encontrar más información sobre cómo descargarla aquí, pero explicaré el caso de la instalación en ubuntu [dapper y edgy] que no sea el Fiesty 7.04 ya que ésta última lleva la versión 2.1.0 de entrada. Si la queréis directamente en catalán, podéis ir a la PD: de éste post.

1- Lo primero de todo es desinstalar la anterior versión del openoffice, para ello iremos al synaptic [Sistema -> Administración -> Gestor de paquetes Synaptic] y buscaremos la palabra openoffice, ordenaremos por la letre E, seleccionaremos todos los paquetes ya instalados, botón derecho -> Marcar para eliminar completamente.

2- Nos descargaremos el openoffice para linux desde la web comentada al principio del post, es el link que pone Linux, lo descomprimimos y entramos desde el terminal dentro de la carpeta que pone RPM. Para poderlo instalar en ubuntu necesitamos transformar todos esos ficheros .rpm a ficheros .deb. Para ello utilizaremos la herramienta alien.
sudo aptitude install alien

Transformamos todos los paquetes:

sudo alien -vdc *.rpm --scripts


Eliminamos lo que no necesitamos:
sudo rm *.rpm


Instalarmos todos los paquetes para ubuntu:
sudo dpkg -i *.deb


Vamos a la carpeta desktop-integration e instalamos el paquete para debian:
cd desktop-integration
sudo dpkg -i *.deb


PD: Si preferís tener el OpenOffice directamente en catalán, como es mi caso, softcatalà ya ha creado todos los paquetes .deb necesarios así que no hace falta perder el tiempo en transformarlos, nos descargaremos éste fichero, lo descomprimimos y dentro de esa carpeta vamos al directorio DEB, allí procedemos a instalarlo todo con un sudo dpkg -i *.deb, lo ejecutamos otra vez sudo dpkg -i *.deb y listo.

2 comentarios:

Anónimo dijo...

hola, llego al último paso y me sale esto.

dpkg: acerca de openoffice.org-debian-menus_2.1-5_all.deb que contiene openoffice.org-debian-menus:
openoffice.org-core conflicts with openoffice.org-unbundled
openoffice.org-debian-menus proporciona openoffice.org-unbundled y va a ser instalado.
dpkg: error al procesar openoffice.org-debian-menus_2.1-5_all.deb (--install):
paquetes en conflicto - no se instalará openoffice.org-debian-menus
Se encontraron errores al procesar:
openoffice.org-debian-menus_2.1-5_all.deb


No se por qué, pero ya usé tu guia una vez y me foncionó.

gracias

Ferran Garriga dijo...

Que raro tu error, igualmente parece ser un conflicto de paquetes.

Mira de desinstalar el paquete [lo puedes hacer a través del synaptic] openoffice.org-unbundled y luego instalar el paquete openoffice.org-debian-menus_2.1-5_all.deb